Swoole Compiler 安装向导

(RiPro需要swoole加密扩展,支持PHP5.6~7.4,推荐7.4)


检查当前环境
  • 操作系统 : Linux localhost.localdomain 2.6.32-754.15.3.el6.x86_64 #1 SMP Tue Jun 18 16:25:32 UTC 2019 x86_64
  • PHP版本 : 7.1.3
  • PHP运行环境 : cgi-fcgi
  • PHP配置文件 : /usr/local/zend/php7.1/etc/php.ini
  • PHP扩展安装目录 : /usr/local/zend/php7.1/include/php/ext
  • PHP是否线程安全 : 非线程安全
  • 是否安装swoole_loader : 未安装

安装和配置Swoole Loader

1 - 点击下载 unix PHP7.1 Swoole Loader扩展文件

2 - 安装Swoole Loader

将刚才下载的Swoole Loader扩展文件(swoole_loader71.so)上传到当前PHP的扩展安装目录中:

/usr/local/zend/php7.1/include/php/ext

3 - 修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

编辑此PHP配置文件:/usr/local/zend/php7.1/etc/php.ini,在此文件底部结尾处加入如下配置

extension=swoole_loader71.so
注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

4 - 重启服务器

重启PHP或者重启服务器